Fake ID fix

Fake ID fix


Patch the system against the Fake ID vulnerability (bug 13678484)

Requires the Xposed Framework. Grab it at http://forum.xda-developers.com/xposed/xposed-installer-versions-changelog-t2714053 and make sure it runs properly on your device.
ROOT only required for installing the Xposed Framework, it can be dropped afterwards.
This app won't do anything without Xposed (not even appear on the launcher).

A great explanation of this vulnerability that currently affects most Android devices can be found on this article by Jeff Forristal from Bluebox: http://bluebox.com/technical/android-fake-id-vulnerability/

To detect if your system is vulnerable you can use Bluebox Security Scanner: https://play.google.com/store/apps/details?id=com.bluebox.labs.onerootscanner


For any questions or to support my work, please visit http://forum.xda-developers.com/xposed/modules/mod-fakeid-vulnerability-fix-t2833854

Recent changes:
* Support for Xposed Framework 2.2 (bridge v30) and above
* Support for Gingerbread 2.3.3 and above (find Xposed for GB here: http://forum.xda-developers.com/xposed/xposed-ported-to-gingerbread-update-to-t2739034)
* Reduced potential for compatibility issues by patching only the system services but not other apps that might be using a private API
Add to list
Free
91
4.6
User ratings
265
Installs
5,000+
Concerns
0
File size
22 kb
Screenshots
Screenshot of Fake ID fix Screenshot of Fake ID fix
About Fake ID fix
Patch the system against the Fake ID vulnerability (bug 13678484)

Requires the Xposed Framework. Grab it at http://forum.xda-developers.com/xposed/xposed-installer-versions-changelog-t2714053 and make sure it runs properly on your device.
ROOT only required for installing the Xposed Framework, it can be dropped afterwards.
This app won't do anything without Xposed (not even appear on the launcher).

A great explanation of this vulnerability that currently affects most Android devices can be found on this article by Jeff Forristal from Bluebox: http://bluebox.com/technical/android-fake-id-vulnerability/

To detect if your system is vulnerable you can use Bluebox Security Scanner: https://play.google.com/store/apps/details?id=com.bluebox.labs.onerootscanner


For any questions or to support my work, please visit http://forum.xda-developers.com/xposed/modules/mod-fakeid-vulnerability-fix-t2833854

Recent changes:
* Support for Xposed Framework 2.2 (bridge v30) and above
* Support for Gingerbread 2.3.3 and above (find Xposed for GB here: http://forum.xda-developers.com/xposed/xposed-ported-to-gingerbread-update-to-t2739034)
* Reduced potential for compatibility issues by patching only the system services but not other apps that might be using a private API

Android Market Comments
A Google User
Apr 18, 2015
Great. Works great if you read and follow directions...
A Google User
Mar 15, 2015
Needs to be rooted? How does that help?
A Google User
Mar 15, 2015
nice
A Google User
Feb 27, 2015
When i download it nothing pop a up cant open it and its no where to be found
A Google User
Jan 23, 2015
This is the kind of thing the community needs Above.
Version 1000000
Version 1000000