GetRIL

GetRIL


** GetRIL Premium ** is available on the Google Play Store! Purchase the Premium version to get the latest changes first, a better looking app and to show me your support and appreciation! :-)

GetRIL shows the device's current RIL (Radio Interface Layer) and baseband, notifying you if they match or not. If not - and you're on a rooted device - you'll be able to download and install a new matching RIL.

FEATURES

• See the device's current RIL & baseband
• Recommends RIL based on the device's baseband version
• Recommends a baseband based on the device's RIL version
• Backup & restoration of the RIL
• Downloading and installation of a new matching RIL
• RIL reporting: your device got an 'Unknown RIL'? Email it to me directly from within the app and I'll try to sort hings out
• Localized to: English, Danish, German, Dutch, French, Czech, Spanish, Italian, Russian, Swedish, Korean, Simplified Chinese, Greek

DEVICE SUPPORT

• LG Optimus 2X (+ G2X), LG Optimus 3D (+ Thrill 4G), LG Optimus Black, LG Optimus 4X, LG Nitro HD
• HTC Desire HD, HTC Sensation 4G, HTC One X, HTC One V, HTC One S
• Samsung Galaxy Nexus (maguro), Samsung Galaxy S, Samsung Galaxy S2, Samsung Galaxy S3, Samsung Galaxy S4, Samsung Galaxy S5
• Google Nexus 4, Nexus 5, Nexus 7
• Sony Xperia Z2

NOTE: some of these devices has preliminary support, meaning that these devices needs more, confirmed, data.

BACKUP & RESTORE

If you accidentally install a faulty RIL you can safely restore a backup of your previous RIL, which is automatically backed up.

There's also the ability to keep the current RIL after a ROM flash. This feature only work on CyanogenMod based ROMs.

HELP & ASSISTANCE

I'll try to keep the app up-to-date when new RILs and basebands get released. Have any information to share with me? Please send me an e-mail.

Need help? Don't hesitate to contact me, but first off - go see the help section within the app.

DISCLAIMER: I don't take liability for any damage your phone might sustain, while/after using this app.

NOTE: if you're recieving "unsupported device" messages it's not on me to blame. I'm sad to see all the negative feedback and ratings I've been getting recently because of this.
The main issue if you're on a supported device, but recieves this message is because either your carrier or ROM developer have changed some values within a file (build.prop). With this release of GetRIL I've made some changes so that I can add your devices as "supported" devices either way... with one caveat: I'll have to do this manually.

Recent changes:
• KitKat users can now enjoy a transparent Navigation bar
• Added support for Nexus 5, Samsung Galaxy S 4 + S 5, Sony Xperia Z2 (more to come!)
• Some minor tweaks

I'll need YOUR help to keep the RIL databases up-to-date for the new devices.
Add to list
Free
83
4.2
User ratings
1805
Installs
100,000+
Concerns
0
File size
966 kb
Screenshots
Screenshot of GetRIL Screenshot of GetRIL Screenshot of GetRIL Screenshot of GetRIL Screenshot of GetRIL Screenshot of GetRIL Screenshot of GetRIL Screenshot of GetRIL
About GetRIL
** GetRIL Premium ** is available on the Google Play Store! Purchase the Premium version to get the latest changes first, a better looking app and to show me your support and appreciation! :-)

GetRIL shows the device's current RIL (Radio Interface Layer) and baseband, notifying you if they match or not. If not - and you're on a rooted device - you'll be able to download and install a new matching RIL.

FEATURES

• See the device's current RIL & baseband
• Recommends RIL based on the device's baseband version
• Recommends a baseband based on the device's RIL version
• Backup & restoration of the RIL
• Downloading and installation of a new matching RIL
• RIL reporting: your device got an 'Unknown RIL'? Email it to me directly from within the app and I'll try to sort hings out
• Localized to: English, Danish, German, Dutch, French, Czech, Spanish, Italian, Russian, Swedish, Korean, Simplified Chinese, Greek

DEVICE SUPPORT

• LG Optimus 2X (+ G2X), LG Optimus 3D (+ Thrill 4G), LG Optimus Black, LG Optimus 4X, LG Nitro HD
• HTC Desire HD, HTC Sensation 4G, HTC One X, HTC One V, HTC One S
• Samsung Galaxy Nexus (maguro), Samsung Galaxy S, Samsung Galaxy S2, Samsung Galaxy S3, Samsung Galaxy S4, Samsung Galaxy S5
• Google Nexus 4, Nexus 5, Nexus 7
• Sony Xperia Z2

NOTE: some of these devices has preliminary support, meaning that these devices needs more, confirmed, data.

BACKUP & RESTORE

If you accidentally install a faulty RIL you can safely restore a backup of your previous RIL, which is automatically backed up.

There's also the ability to keep the current RIL after a ROM flash. This feature only work on CyanogenMod based ROMs.

HELP & ASSISTANCE

I'll try to keep the app up-to-date when new RILs and basebands get released. Have any information to share with me? Please send me an e-mail.

Need help? Don't hesitate to contact me, but first off - go see the help section within the app.

DISCLAIMER: I don't take liability for any damage your phone might sustain, while/after using this app.

NOTE: if you're recieving "unsupported device" messages it's not on me to blame. I'm sad to see all the negative feedback and ratings I've been getting recently because of this.
The main issue if you're on a supported device, but recieves this message is because either your carrier or ROM developer have changed some values within a file (build.prop). With this release of GetRIL I've made some changes so that I can add your devices as "supported" devices either way... with one caveat: I'll have to do this manually.

Recent changes:
• KitKat users can now enjoy a transparent Navigation bar
• Added support for Nexus 5, Samsung Galaxy S 4 + S 5, Sony Xperia Z2 (more to come!)
• Some minor tweaks

I'll need YOUR help to keep the RIL databases up-to-date for the new devices.

User reviews of GetRIL
Allowed me to download the correct RIL. Easy! Best with CyanogenMOd.
Jul 30, 2011
Android Market Comments
A Google User
Dec 14, 2014
Excellent
A Google User
Dec 5, 2014
Support for LG G Pro Support for LG G Pro F240k required
A Google User
Dec 2, 2014
please Nexus 6 support, please :)
A Google User
Nov 27, 2014
I have a Samsung galaxy s5, yet it says its unsupported. So, since it doesn't function correctly, I'm rating it at 1 star, wish I could do 0.
A Google User
Oct 31, 2014
Not support my S4 version 😭