ScreenConnect Legacy

ScreenConnect Legacy


WORKS WITH SCREENCONNECT 4.4 OR HIGHER. USE "SCREENCONNECT LEGACY LEGACY" APP FOR OLDER VERSIONS OR NORMAL "SCREENCONNECT" APP FOR NEWER VERSIONS.

Use this ScreenConnect Client to join sessions in an existing instance of ScreenConnect. If you don't have access to ScreenConnect already, visit http://www.screenconnect.com/ to become acquainted with the best remote support software available today.

Recent changes:
Bug fixes
Add to list
Free
85
4.3
User ratings
227
Installs
10,000+
Concerns
0
File size
480 kb
Screenshots
Screenshot of ScreenConnect Legacy Screenshot of ScreenConnect Legacy Screenshot of ScreenConnect Legacy Screenshot of ScreenConnect Legacy Screenshot of ScreenConnect Legacy Screenshot of ScreenConnect Legacy Screenshot of ScreenConnect Legacy
About ScreenConnect Legacy
WORKS WITH SCREENCONNECT 4.4 OR HIGHER. USE "SCREENCONNECT LEGACY LEGACY" APP FOR OLDER VERSIONS OR NORMAL "SCREENCONNECT" APP FOR NEWER VERSIONS.

Use this ScreenConnect Client to join sessions in an existing instance of ScreenConnect. If you don't have access to ScreenConnect already, visit http://www.screenconnect.com/ to become acquainted with the best remote support software available today.

Recent changes:
Bug fixes

Android Market Comments
A Google User
Jun 16, 2015
Glad to find this. Connected up to my labtech screenconnect and was able to control my agents. BOOM! Now they need to get labtech integrated with it
A Google User
Jun 8, 2015
Doesn't work anymore An older version used to work for me. Since updating it doesn't work any more. Connecting to any client just gives me a black screen. Also did the same on my old ROM and previous (currently on lollipop, previously kitkat). Also does the same on my S4.
A Google User
Jun 1, 2015
Does not work past “4.4 or higher" Your 4.4 or higher statement is completely false. Please get it working and I'll change my rating. It's been several months and I can't support my clients. I have to RDP to a server then ScreenConnect from there. Please, please fix. I bought this with the fact it were Mobile supported but as soon as the first update comes it, it's been months of not working.
A Google User
May 31, 2015
Needs two things.. allow resolution changing from the client.. pan with the mouse
A Google User
Apr 15, 2015
Great program, but... Needs to be updated to work with Android 5.1+. Please fix, as I use it daily. Tested on Nexus 6.
Version 1000000
Version 1000000