AppBrain
AppBrain
  • Apps
  • Apps being viewed right now Trending apps today Most popular apps All-time most downloaded apps Top rated apps iPhone and iPad apps
  • Intelligence ▾
    Intelligence overview → Track any Android app or your whole market
    Track & analyze
    Keyword Tracker & OptimizerTrack & improve Play rankings App Performance ReportOne-off PDF for any app StatisticsFree Android & Play market stats
    Promote your app
    Featured Apps App Links
  • Intelligence
  • Pricing
  • Dashboard
  • Sign up
  • Log in
App Store Apps > Business > Sky Networks SkyPhone
App profile · Business
Sky Networks SkyPhone icon

Sky Networks SkyPhone

by Sky VC Networks LLC · Free · Version 2.12.5
Availability No longer on the App Store
Rating on App Store
5.00/5
2 ratings
Rating
5.00
2 reviews
Best rank
–
not in the top lists
Last updated
February 15, 2022
2.12.5
AppBrain's verdict Established

It doesn't have enough ratings yet to judge what users think.

Sky Networks SkyPhone is made and published by Sky VC Networks LLC. AppBrain is an independent app data site and isn't affiliated with Sky VC Networks LLC. The app name, icon, screenshots and description belong to Sky VC Networks LLC and are shown as published on the App Store.

About Sky Networks SkyPhone

Sky Networks SkyPhone was a business app developed by Sky VC Networks LLC. It was removed from the App Store Nov 23, 2025.

User Ratings

Sky Networks SkyPhone was rated 5.00 out of 5 stars, based on 2 ratings.

App Information

Sky Networks SkyPhone was free. The app size was 31.22 MB. The last available version was 2.12.5. The last update was on February 15, 2022.

Technical Requirements

The app had a content rating of Everyone. The app had been available on the App Store since August 2014.

Description by Sky VC Networks LLC (from the App Store)
Sky Network's "Skyphone" app leverages the the latest technology to offer, SIP based voice, video and text messaging services on iOS (iphone, ipad). Based on 3GPP IMS (IP Multimedia Subsystem standards , SkyPhone is designed as an OEM product that can be customized to fit service providers exact needs. It is perfect for service providers that offer wholesale, international and prepaid VoIP services to enterprise and retail customers. The incorporated SIP stack follows RFC 3261 and 3GPP TS 24.229 Rel-9 specifications, this will allow you to connect to any compliant SIP registrar. It also partially implements GSMA Rich Communication Suite release 3 and The One Voice profile V1.0.0 (LTE/4G, also known as GSMA VoLTE) specifications. The phone is setup to be centrally provisioned using encrypted https and our standard installation includes the provisioning server. It also features a visual voicemail with preintegrated implementations for Freeswitch based voicemail systems. The phone includes support for the STUN (RFC 3489/RFC 5389), ICE (RFC 5245) and TURN (RFC 5766) specifications allowing it to be used with the Sky Dance STUN/ICE/TURN Media server independently of a session border controller for far end NAT traversal or in conjunction with a SBC depending on scale and needs.
Show more Show less
Price Free
Rating 5.00 based on 2 ratings
Version 2.12.5
App size 31.2 MB
Suitable for Everyone
This app is currently not available on the App Store.

Similar apps

Platon Phone icon Platon Phone
Platon
0.0
Free
1CRM Client icon 1CRM Client
1CRM Corp.
0.0
Free
Sipharmony icon Sipharmony
Sip Harmony LLC
0.0
Free
VoicePort icon VoicePort
Bilal Ahmed
5.0
Free
1 ratings
I'm InTouch Go icon I'm InTouch Go
01 Quantum Inc.
3.0
Free
2 ratings
pascom Client icon pascom Client
pascom GmbH
0.0
Free
Cloud-PBX icon Cloud-PBX
World Phone Internet Services Private Limited
4.0
Free
4 ratings
VARTA AMP100 icon VARTA AMP100
Matrix ComSec Pvt. Ltd.
0.0
Free

Screenshots

Screenshots of this removed app
We kept the screenshots from before it was removed. Subscribe to see them.

Changelog of Sky Networks SkyPhone

No changelog data

Developer information for Sky VC Networks LLC

Sky VC Networks LLC

Address:

Share Sky Networks SkyPhone

Comments on Sky Networks SkyPhone for iOS

We don't have enough comments to show example comments. Please check back later.

Technologies used by Sky Networks SkyPhone

Top new apps Price drops on Google Play Today's trending apps Apps other people are watching Popular Business Apps
Platon Phone icon Platon Phone
1CRM Client icon 1CRM Client
Sipharmony icon Sipharmony
VoicePort icon VoicePort
I'm InTouch Go icon I'm InTouch Go
pascom Client icon pascom Client
Cloud-PBX icon Cloud-PBX
VARTA AMP100 icon VARTA AMP100
Overview Reviews Technology
AppBrain Intelligence premium content

Subscribe now to get full and unlimited access to AppBrain Intelligence. You'll have access to:

  • App Intelligence dashboard (performance timeline, competitor comparison, country rankings, insight cards)
  • Detailed ranking data per app
  • Full timeline per developer
  • Device market shares data per country
  • Unlimited keyword tracking
1 Month

$75/mo
(billed every month)

SAVE 0%
Subscribe
3 Months

$65/mo
($195 billed every 3 months)

SAVE 13%
Subscribe
1 Year

$57.50/mo
($690 billed every year)

SAVE 23%
Subscribe
Each subscription will automatically renew 3 days before the expiration date for the same time period. Subscriptions can be cancelled at any time before the renewal.

AppBrain is an app data site, we track rankings, ratings, installs for all apps and games on Google Play and the App Store. AppBrain doesn't host app files or APKs, all install links go directly to the official store. All trademarks are owned by their respective owners.

More apps

  • Top Android apps being viewed
  • Accio: Alibaba AI Agent
  • UmCAService stats
  • Unicorn Milkshake for Android

App statistics

  • Android statistics
  • Google Play Developer stats
  • Trending Android Apps
  • Trending iOS apps
  • Top popular Apps
  • Buy the best Android phone
  • Buy & sell app businesses

About AppBrain

  • Contact
  • Privacy
  • Documentation
  • DMCA takedowns
  • Articles
  • Blog
  • Free App-Ads.Txt Validation
© 2010-2026 - AppBrain